Topic: Rendering MIDI data

I really like GuitarStudio, but I have found a couple problems when rendering a recording as a MIDI file:

1.  The file ends up an octave higher than it should have been.  That is easy enough to fix manually, but the second problem isn't so easy:

2.  When rendering a MIDI file, it seemed to ignore the alternate tuning of the guitar, and it rendered based on standard tuning, which obviously made the song sound wrong.

Is there an option I missed?  Can anybody help me out with this?

Thanks.

Re: Rendering MIDI data

Hello Admiral,

1. Wow. Gotta say you're so right about that. While there is some confusion in the world about MIDI octave note naming, the generated note numbers are off by an octave.

2. And yup, that's a bug that we didn't catch.

You didn't miss any options ... the issue is on our end. Please look for an update soon that will address these two mistakes.

And let me also add *THANKS* for using our forum and pointing out these issues. While we cannot provide every user with every feature request, we do appreciate your feedback, especially on bugs like this.

Re: Rendering MIDI data

BTW, v1.99 of GuitarStudio and iShred are submitted for review to Apple. This version fixes the two issues you brought up. Thanks again, and look in about a week for an update.

Re: Rendering MIDI data

Thanks for the quick response and thanks even more for the quick fix.  This is a great program, and I'm glad I finally bit the bullet and paid the $5 for it (it is certainly cheaper than a $200+ acoustic-electric guitar, anyway).  I'll keep my eye out for the update.

Re: Rendering MIDI data

Just tried out the update, and rendering MIDI works perfectly.  Thanks for the attention again.

Re: Rendering MIDI data

Great! Was just going to post that the update had been approved. ":^)