Topic: Bank button editing bug/error and non-function after editing

When I attempt to re-label the bank buttons, all bank buttons become inoperable. The editor will cannot re-label the button, the keyboard does not slide up for editing, the other four bank buttons "grey-out" and become non-functional.
Even after I exit the editor and return to play mode the damage to the bank buttons has been done. I cannot switch between banks at all. This "bug" is evident for all songs, created or the songs preloaded with the app.
The only way to restore bank button functionality is to completely exit out of the app and restart the app again. The editor cannot be used on the bank buttons.
I am using an iPod Touch 2nd generation w/ iOS 4.1 software. I have re-booted both ways, by shutting off completely or holding the sleep and hold keys, but to no avail.  PLEASE ADVISE because I love this app!!!!!

Re: Bank button editing bug/error and non-function after editing

Wow. Thank you for reporting this. Not sure when this bug appeared, or what is causing it (yet), but it is easily reproduced. We will try to investigate it real soon and submit a fix to Apple.

Again, thanks for notifying us. Our bad, but we'll get on it right away.

Re: Bank button editing bug/error and non-function after editing

Thank you for your quick and responsible reply. Wish more techs were this efficient. I will be anticipating your fix. Good luck!

Re: Bank button editing bug/error and non-function after editing

Hey marcmarq524,

Wanted to let you know that we just submitted a PianoStudio update to Apple that fixes this bug.

We also wanted to add something fun, so included in this version is a new instrument: Wurlitzer electric piano. We've been having fun at work with this classic instrument, and hope you will, too.